Monthly FFR data visualisation
Incident Report for Modo Energy
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 15:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 21, 2021 - 15:13 UTC
Identified
It appears that monthly FFR has been lost - unfortunately the platform automatically updates when monthly FFR data is usually published. Once National Grid publishes the auction results this data will be updated. You are still able to review previous auctions, including the auction currently active.

A modification to our frontend currently being made will stop this from reoccurring.
Posted Jan 18, 2021 - 11:26 UTC
This incident affected: The Platform (Monthly FFR).